[Solved]react-redux v6 a v3.*.* version of react-redux-firebase is required

I’ve been working on a project using react-redux-firebase, which has worked for me before. today I got the following error:

Error: Context from react-redux not found. If you are using react-redux v6 a v3.*.* version of react-redux-firebase is required. Please checkout the v3 migration guide: http://bit.ly/2SRNdiO

I’m not sure if the error is somewhere else in my code or if I have to update react-redux-firebase to version 3.., which doesn’t seem to exist as of now.

Finally it worked for me to fix the error by following this method:

Installing older library version using npm

npm install react-redux@^5.1.1

Tags: , , , , , ,
Author:

Murtaza

Agha Murtaza is a web designer and WordPress developer with over one year of experience. You can visit his business site here . Murtaza is the CEO of codingle.com. He also has an opinion on just about every subject. You can follow his rants on Twitter @murtaxa_n.